SaltyCajun.com http://www.matrixshad.com//

Notices

Go Back   SaltyCajun.com > Hobby Forums > Offroad Forum (4x4 & ATV)

Offroad Forum (4x4 & ATV) Discuss anything to do with offroad sports here, including ATVs, mudding in your truck, etc.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-11-2011, 08:16 PM
homerun homerun is offline
Trophy Trout
 
Join Date: May 2009
Location: lake charles
Posts: 472
Cash: 907
Default code p0304 ford f150

cleaned and re oiled my k n air filter. now it runs rough and engine light on. code says p0304. which is saying cylinder 4. i cleaned my map sensor and bought new air filter just in case too much oil from air filter, but same thing question is should i buy a new $100 map sensor and see if works. or should i take it in to have someone take out #4 plug and look at it.
Reply With Quote
  #2  
Old 08-11-2011, 08:19 PM
southern151's Avatar
southern151 southern151 is offline
Blue Marlin
 
Join Date: May 2009
Location: Gonzales
Posts: 8,705
Cash: 3,446
Default

Likely a misfire on your number 4 injector. Could be many things that cause that. Let it ride and see if it clears. If not, seek assistance
Reply With Quote
  #3  
Old 08-11-2011, 08:19 PM
Dink's Avatar
Dink Dink is offline
Blue Marlin
 
Join Date: May 2009
Location: Lafayette
Posts: 7,768
Cash: 2,092
Default

On my computer, That code came up as "Buy a Dodge"
Reply With Quote
  #4  
Old 08-11-2011, 08:19 PM
weedeater's Avatar
weedeater weedeater is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff, La
Posts: 5,057
Cash: 2,364
Default

think Advance Auto has a code reader
Reply With Quote
  #5  
Old 08-11-2011, 08:26 PM
homerun homerun is offline
Trophy Trout
 
Join Date: May 2009
Location: lake charles
Posts: 472
Cash: 907
Default

autozone read it for the code. how long to drive it to see if clears up. and would driving it mess something else up.
Reply With Quote
  #6  
Old 08-11-2011, 08:31 PM
Dink's Avatar
Dink Dink is offline
Blue Marlin
 
Join Date: May 2009
Location: Lafayette
Posts: 7,768
Cash: 2,092
Default

Don't touch the map sensor. All it reads is load. Fords have a single coil over each spark plug and they are notorious for going out......it prolly wont clear up, but you can pull the plug, clean it, clear the code and see what happens
Reply With Quote
  #7  
Old 08-11-2011, 08:35 PM
weedeater's Avatar
weedeater weedeater is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff, La
Posts: 5,057
Cash: 2,364
Default

Quote:
Originally Posted by Dink View Post
Don't touch the map sensor. All it reads is load. Fords have a single coil over each spark plug and they are notorious for going out......it prolly wont clear up, but you can pull the plug, clean it, clear the code and see what happens

what yr truck? I had a 97 and 01 and both had problems with coils
Reply With Quote
  #8  
Old 08-11-2011, 08:39 PM
homerun homerun is offline
Trophy Trout
 
Join Date: May 2009
Location: lake charles
Posts: 472
Cash: 907
Default

2003 f150 5.4. read from others if i had excess oil on filter it could have contaminated map sensor. which would could have sent wrong mixture to plugs which is what fouled it up. how hard is it to remove plug in the 4 slot on this ford.
Reply With Quote
  #9  
Old 08-11-2011, 08:39 PM
wtretrievers's Avatar
wtretrievers wtretrievers is offline
Ling
 
Join Date: May 2009
Location: Central
Posts: 3,690
Cash: 2,427
Default

Disconnect battery terminals for at least 5 mins. & see if it clears. Also check that plug wire & make sure it's nit touching metal or another plug wire, they will jump fire, sometimes you can crank engine after dark with no lights & see fire jumping, sounds like there's a misfire, could be a plug wire or that coil.
Reply With Quote
  #10  
Old 08-11-2011, 08:41 PM
1fastmerc's Avatar
1fastmerc 1fastmerc is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff
Posts: 4,680
Cash: 1,405
Default

Quote:
Originally Posted by Dink View Post
On my computer, That code came up as "Buy a Dodge"
Mine too


---
- Sent from my iPhone using Tapatalk
Reply With Quote
  #11  
Old 08-11-2011, 08:44 PM
weedeater's Avatar
weedeater weedeater is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff, La
Posts: 5,057
Cash: 2,364
Default

Quote:
Originally Posted by 1fastmerc View Post
Mine too


---
- Sent from my iPhone using Tapatalk
maybe you should drop a dodge on that boat
Reply With Quote
  #12  
Old 08-11-2011, 08:50 PM
homerun homerun is offline
Trophy Trout
 
Join Date: May 2009
Location: lake charles
Posts: 472
Cash: 907
Default

went and disconnected. i'll go check in a little bit. sounds like a good idea though to reset the system. i've been told it was difficult to get to the back spark plug. what ya think. it looks awkward for sure
Reply With Quote
  #13  
Old 08-11-2011, 08:54 PM
weedeater's Avatar
weedeater weedeater is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff, La
Posts: 5,057
Cash: 2,364
Default

Quote:
Originally Posted by homerun View Post
went and disconnected. i'll go check in a little bit. sounds like a good idea though to reset the system. i've been told it was difficult to get to the back spark plug. what ya think. it looks awkward for sure
Ford did a tune up on my 05 and by the time they got the back plugs out they had the cab off, how adventures are you
Reply With Quote
  #14  
Old 08-11-2011, 08:57 PM
wtretrievers's Avatar
wtretrievers wtretrievers is offline
Ling
 
Join Date: May 2009
Location: Central
Posts: 3,690
Cash: 2,427
Default

Quote:
Originally Posted by homerun View Post
went and disconnected. i'll go check in a little bit. sounds like a good idea though to reset the system. i've been told it was difficult to get to the back spark plug. what ya think. it looks awkward for sure
What I think is the SOB's that build this should have to work on it!!!!! I hate engineers!!!!!
Reply With Quote
  #15  
Old 08-11-2011, 09:10 PM
homerun homerun is offline
Trophy Trout
 
Join Date: May 2009
Location: lake charles
Posts: 472
Cash: 907
Default

connected battery back. check engine light went off , took for a 3 mile spin and still riding rough. i did also spray some carb /choke cleaner in the intake. wonder if some loosened up junk sucked in would make it run like this????
Reply With Quote
  #16  
Old 08-11-2011, 09:15 PM
weedeater's Avatar
weedeater weedeater is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff, La
Posts: 5,057
Cash: 2,364
Default

does it run any diff when it ideals then when you are driveing?If I remember right mine would ideal pretty close to normal but when you gave it gas it was like it had a miss
Reply With Quote
  #17  
Old 08-11-2011, 09:19 PM
homerun homerun is offline
Trophy Trout
 
Join Date: May 2009
Location: lake charles
Posts: 472
Cash: 907
Default

if in neutral its idles perfect. at the red light in gear it wants to struggle. floor it and it goes pretty close to normal . its when let off gas it gets rough
Reply With Quote
  #18  
Old 08-11-2011, 09:22 PM
weedeater's Avatar
weedeater weedeater is offline
Sailfish
 
Join Date: Mar 2011
Location: Moss Bluff, La
Posts: 5,057
Cash: 2,364
Default

sounds like coil, I had a problem also with the cat. pluging but it would ideal ok but struggle when you gave it gas in gear
Reply With Quote
  #19  
Old 08-11-2011, 09:45 PM
Tex Dawg's Avatar
Tex Dawg Tex Dawg is offline
Redfish
 
Join Date: May 2011
Location: Texas
Posts: 208
Cash: 801
Default

replace #4 coil,they are about $60,just one bolt & a plug,this is a commonproblem on fords.
Reply With Quote
  #20  
Old 08-11-2011, 10:23 PM
Jordan's Avatar
Jordan Jordan is offline
Great White
 
Join Date: May 2009
Location: DeRidder,LA
Posts: 10,399
Cash: 2,434
Default

Just had #4 ignition coil replaced on an '04 ford last week. $65 and took about an hour.( they had to find the right tools) works fine now, it would "miss" when in OD and when I would give it a little gas
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:38 PM.



Powered by vBulletin®
Copyright ©2000 - [ARG:3 UNDEFINED], Jelsoft Enterprises Ltd.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios
SaltyCajun.com logo provided by Bryce Risher

All content, images, designs, and logos are Copyright © 2009-2012,
Salty Cajun, LLC
No unathorized use is permitted
Geo Visitors Map